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           introduction to Word( 2007) 

 
          Word 2007 is the word processing software in the Microsoft 2007 Office 
Suite. It allows you to easily create a variety of professional-looking documents 
using features such as themes, styles, Smart Art, and more. 

Lessons 
1-Creating a New Document 

    Formatting Text  

   Format Font Size 

   Format Font Style 

   Format Font Color 

   Change the Text Case 

   Change Text Alignment 

  Using Indents and Tabs 

  Find and Replace to Replace Existing Text     

  Copy and Paste Text     

  Drag and Drop Text 

2-Saving Documents       

3- Printing  

4-Inserting Tables 

  Modifying Page Layout 

 Format Page Margins 

 Insert a Blank Table: 

 Inserting and Modifying Tables 

 Add a Row Above an Existing Row: 

 Add a Column: 

 Delete a Row or Column 

  Apply a Table Style: 

Modify a Table Using the Layout Tab 

5-Text Boxes 

 Insert a Text box: 

Change Text Box Style 

        Change Shape Fill 

6- Shapes 

  Locate Clip Art: 

  Modifying Page Layout 

 Introduction 

 Change the Paper Size 

http://www.gcflearnfree.org/word2007/1
http://www.gcflearnfree.org/word2007/1
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Creating a New Document 

1-    New Documents 

  To Create a New, Blank Document: 

Click the Microsoft Office Button.  

Select New. The New Document dialog box appears.  

Select Blank document under the Blank and recent section. It will be 
highlighted by default. 

 

 

Click Create. A new, blank document appears in the Word window. 
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2-Formatting Text 

 

 

 

To create and design effective documents, you need to know how to format 
text. In addition to making your document more appealing, formatted text 
can draw the reader's attention to specific parts of the document and help 
communicate your message.  
format the font size, style, and color; and use the Bold, Italic, Underline, and 
Change Case commands 

   To Format Font Size: 

Select the text you wish to modify.  

Left-click the drop-down arrow next to the font size box on the Home tab. 
The font size drop-down menu appears.  

Move your cursor over the various font sizes. A live preview of the font  

size will appear in the document. 
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Left-click the font size you wish to use. The font size will change in the 
document. 

To Format Font Style: 

Select the text you wish to modify.  

Left-click the drop-down arrow next to the font style box on the Home tab. 
The font style drop-down menu appears.  

Move your cursor over the various font styles. A live preview of the font will 
appear in the document. 
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Left-click the font style you wish to use. The font style will change in the 
document. 

  

 

To Format Font Color: 

Select the text you wish to modify.  

Left-click the drop-down arrow next to the font color box on the Home tab. 
The font color menu appears.  

Move your cursor over the various font colors. A live preview of the color will 
appear in the document. 
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Left-click the font color you wish to use. The font color will change in the 
document. 

Your color choices aren't limited to the drop-down menu that appears. Select 
More Colors at the bottom of the list to access the Colors dialog box. Choose 
the color that you want and click OK 

   To Use the Bold, Italic, and Underline Commands: 

Select the text you wish to modify.  

Click the Bold, Italic, or Underline command in the Font group on the Home 
tab. 
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To Change the Text Case: 

Select the text you wish to modify.  

Click the Change Case command in the Font group on the Home tab.  

Select one of the case options from the list. 

 

 

To Change Text Alignment: 

Select the text you wish to modify.  

Select one of the four alignment options from the Paragraph group on the 
Home tab.  

Align Text Left: Aligns all the selected text to the left margin.  

Center: Aligns text an equal distance from the left and right margins.  

Align Text Right: Aligns all the selected text to the right margin.  

Justify: Justified text is equal on both sides and lines up equally to the right 
and left margins. Traditionally many books, newsletters, and newspapers use 
full-justification. 
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Formatting Text 

Using Indents and Tabs 

        The Tab Selector 

The tab selector is above the vertical ruler on the left. Hover over the tab 
selector to see the name of the type of tab that is active.  

 

 
The tab options are: 

First Line Indent : Inserts the indent marker on the ruler and indents the 
first line of text in a paragraph.  

Hanging Indent : Inserts the hanging indent marker and indents all lines 
other than the first line.  

Left Tab : Moves text to the right as you type.  

Center Tab : Centers text according to the tab.  

Right Tab : Moves text to the left as you type.  

Decimal Tab : Aligns decimal numbers using the decimal point.  

Bar Tab : Draws a vertical line on the document.  

 To Set a Tab Stop to Indent the First Line of Text: 

Click the tab selector until the First Line Indent icon is visible.  

Left-click at any point on the horizontal ruler. 

 The First Line Indent icon will appear.  

 The tab options are: 

      To Set a Tab Stop to Indent the First Line of Text: 

    Click the tab selector until the First Line Indent icon is visible.  

    Left-click at any point on the horizontal ruler.  

   The First Line Indent icon will appear.  

Lyath
Выделение
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Press the Enter key to start a new paragraph and your insertion point will 
automatically indent to that point.  
To move a tab stop once you have inserted it, left-click and drag the tab stop 
back and forth on the ruler. 
You can set the Hanging Indent the the same way; however this tab stop 
changes all the other lines in a paragraph.  

       To Set the Left, Center, Right, and Decimal Tab Stops: 

    Click the tab selector until the tab stop you wish to use appears.  

Left-click the location on the horizontal ruler where you want your text to         
appear.                                                                                                      

 

Press the Tab key to reach the tab stop.   

 

   Use Find and Replace to Replace Existing Text: 

Click the Replace command on the Home tab. The Find and Replace dialog box 
appears. 
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Enter text in the Find field that you wish to locate in your document.  

Enter text in the Replace field that will replace the text in the Find box. 

 

 

 

Click OK. The change is made in the document. 

You can also use the Find command to locate specific information in a 
document. For example, if you are working with a twenty page report, it would be 
time consuming to search the document for a specific topic. You can use the 
Find command to locate all instances of the word or phrase in the document. 
This is a great way to save time when working with long documents. 

 

    To Copy and Paste Text : 

Select the text you wish to copy.  

Click the Copy command on the Home tab.  

Place your insertion point where you wish the text to appear.  

Click the Paste command on the Home tab. The text will appear. 
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   Saving Documents 

 
 

 

 

It is important to know how to save the documents you are working with. There 
are many ways you share and receive documents, which will affect how you 
need to save the file.  
 
Are you downloading the document? Saving it for the first time? Saving it as 
another name? Sharing it with someone that does not have Word 2007? All of 
these things will affect how you save your Word documents. you will learn how 
to use the save and save as commands, how to save as a Word 97-2003 
compatible document, and how to save as a PDF. 
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 2 - How to Save Documents 

To Use the Save As Command: 

Click the Microsoft Office Button.  

Select Save As Word Document. The Save As dialog box appears.  

 
Select the location you wish to save the document using the drop-down menu.  

Enter a name for the document.  
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Click the Save button.  

    To Use the Save Command: 

Click the Microsoft Office Button.  

Select Save from the menu.  

Using the Save command saves the document in its current location using the 
same file name. If you are saving for the first time and select Save, the Save As 
dialog box will appear 

     To Save As Word 97 - 2003 Document: 

Click the Microsoft Office Button.  

Select Save As Word 97-2003 Document. 
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Select the location you wish to save the document using the drop-down menu.  

Enter a name for the document.  

Click the Save button. 

To Download the PDF Extension: 

Click the Microsoft Office Button.  

Select Save As Find add-ins for other file formats. This will open your web 
browser to the Microsoft site.  

Follow the instructions on the Microsoft site for downloading the extension.  

To Save As a PDF: 

Click the Microsoft Office Button.  

Select Save As PDF. The Save As dialog box will appear. 
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Select the location you wish to save the document using the drop-down menu.  

Enter a name for the document.  

Click the Publish button. 

  

 3- Printing 

Once you complete your document, you may want 
to print it for various reasons. three basic features of printing in Word including 
Print Preview, Quick Print, and traditional Print. 

 

Printing 

 To Preview the Document Before Printing: 

Click the Microsoft Office Button.  

Select Print Print Preview. The document opens in Print Preview format 
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Click Print to print the document or Close Print Preview to exit the preview 
format and make changes to the document. 

In Print Preview format, you can do many tasks including:  

To Print: 

 

Click the Microsoft Office Button.  

Select Print Print. The Print dialog box appears.  

Select the pages you would like to print -- either all pages or a range of pages.  

Select the number of copies.  

Check the Collate box if you are printing multiple copies of a multi-page 
document.  

Select a printer from the drop-down list. 
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Click OK. 

To Print via Quick Print: 

Click the Microsoft Office Button.  

Select Print Quick Print.  

The document automatically prints to the default printer 

 

4- Inserting Tables 

A table is a grid of cells arranged in rows and 
columns. Tables can be customized and are useful for various tasks such as 
presenting text information and numerical data.  
 
how to convert text to a table, apply table styles, format tables, and create blank 
tables 
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  To Insert a Blank Table: 

Place your insertion point in the document where you want the table to 
appear.  

Select the Insert tab.  

Click the Table command.  

Drag your mouse over the diagram squares to select the number of columns 
and rows in the table.  

 

Left-click your mouse and the table appears in the document.  

Enter text into the table 

 Inserting and Modifying Tables 

  To Convert Existing Text to a Table: 

Select the text you wish to convert.  

Select the Insert tab.  

Click the Table command.  

Select Convert Text to Table from the menu. A dialog box appears. 
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Choose one of the options in the Separate text at: section. This is how 
Word knows what text to put in each column.  

 
Click OK. The text appears in a table. 
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  To Add a Row Above an Existing Row: 

Place the insertion point in a row below the location you wish to add a row. 

 
Right-click the mouse. A menu appears.  

Select Insert Insert Rows Above.  

 
  

 

 

A new row appears above the insertion point 

.  
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   To Add a Column: 

Place the insertion point in a column adjacent to the location you wish the 
new column to appear.  

Right-click the mouse. A menu appears.  

Select Insert Insert Columns to the Left or Insert Columns to the 
Right.  A new column appears. 

 To Delete a Row or Column: 

Select the row or column.  

Right-click your mouse and a menu appears.  

Select Delete Columns or Delete Rows 

 

Table Style  

  To Apply a Table Style: 

Select the table. A Table Tools Design tab now appears on the Ribbon.  

Select the Design tab to access all the Table Styles and Options. 

 
Click through the various styles in the Table Styles section.  

Left-click a style to select it. The table style will appear in the document. 

 

You can modify which table styles are displayed. In the Table Styles 
Options you can select and deselect various table options. 
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 For example, you can select Banded Rows and only tables with banded 
rows will appear in the Tables Styles section. 

Want to have a little more creative freedom when it comes to formatting your 
tables? You can manually change the table border or shading, change line 
weight, or erase part of the table.  

Modify a Table Using the Layout Tab 

When you select a table in Word 2007, Design and Layout tabs appear 
under Table Tools on the Ribbon. Using commands on the Layout tab you 
can make a variety of modifications to the table such as: 

Adding and deleting columns,  

Adding and deleting rows,  

Changing the cell size,  

Aligning cell text,  

Changing text direction,  

Merging and splitting cells,  

And More. 

 
 

 

 

 5-Text boxes 

You may want to insert a text box into your 
document to draw attention to specific text or so that you have the ability to 
easily move text around within a document.  
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  Text Boxes 

To Insert a Text box: 

Select the Insert tab on the Ribbon.  

Click the Text Box command in the Text group.  

Select a Built-in text box or Draw Text Box from the menu.  

If you select Built-in text box, left-click the text box you wish to use and it will 
appear in the document. 
OR 

If you select Draw Text Box, a crosshair cursor will appear. Left-click your 
mouse and while holding it down, drag your mouse until the text box is the 
desired size. 

 
Release the mouse button. 

  To Change Text Box Style: 

Select the text box. A new Format tab appears with Text Box Tools. 
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Select the Format tab.  

Click the More drop-down arrow in the Text Box Style group to display more 
style options. 

 
 

 

 

Move your cursor over the styles and Live Preview will preview the style in  

your document.  

Left-click a style to select it. 

  To Change Shape Fill: 

6- Shapes 

Select the text box. A new Format tab appears with Text Box Tools. 
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Click the Shape Fill command to display a drop-down list.  

Select a color from the list, choose No Fill, or choose one of the other 
options 

 
Select a color from the list, choose, or choose one of the other options. 

   To Change the Text Box Shape:  

Select the text box. A new Format tab appears with Text Box Tools.  

Click the Change Shape command to display a drop-down list. 
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Select a shape from the list. 

 

 7- Inserting Clip Art: 

    To Locate Clip Art: 

   Select the Insert tab.  

Click the Clip Art command in the Illustrations group. 

 

The Clip Art options appear in the task pane on the right.  

Enter keywords in the Search for: field that are related to the image you wish 
to insert.  

Click the drop-down arrow next to the Search in: field.  
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Select Everywhere to ensure that Word searches your computer and its 
online resources for an image that meets your criteria.  

Click the drop-down arrow in the Results should be: field.  

Deselect any types of images you do not wish to see. 

 

Click Go. 

To Insert Clip Art: 

Review the results from a clip art search.  

Place your insertion point in the document where you wish to insert the clip 
art.  

Left-click an image in the task pane. It will appear in the document. 
OR 

Left-click the arrow next to an image in the task pane.  

Select Insert, Copy, or any of the other options on the list. 



   Assistant Lecturer  Sherna Aziz Toma 
Page 29 

 

 

 

Modifying Page Layout 

Introduction 

You may find that the default page layout 

settings in Word are not sufficient for the document you wish to create, in 
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which case you will want to modify those settings. In addition, you may want 
to change the page formatting depending on the document you are creating. 
How to change the page orientation, paper size, and page margins, and 
insert a break. 

Page Layout and Formatting 

  To Change Page Orientation: 

Select the Page Layout tab.  

Click the Orientation command in the Page Setup group. 

 

Left-click either Portrait or Landscape to change the page orientation. 

Landscape format means that everything on the page is oriented horizontally 
and portrait format is oriented vertically. 

To Change the Paper Size: 

Select the Page Layout tab.  

Left-click the Size command and a drop-down menu will appear. The current 
paper size is highlighted. 
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Left-click a size option to select it. The page size of the document changes 

Modifying Page Layout 

  To Format Page Margins: 

Select the Page Layout tab.  

Click the Margins command. A menu of options appears. Normal is selected 
by default.  

Left-click the predefined margin size you want.  
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OR  

Select Custom Margins from the menu. The Page Setup dialog box appears. 

 

 

 

Enter the desired margin size in the appropriate fields. 

You can always access the Page Setup dialog box by clicking the small arrow 
in the bottom-right corner of the Page Setup group. The dialog box should 
look familiar to people who have used previous versions of Word. 


